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UNIT 1 COMPUTER BASICS

Characteristics of a computer - Classification of
Computers – Computer Organization and
Architecture – Central Processing Unit –
Communication among various units – Inside a
Computer – Data Representation – Number System.

Computer Memory and Storage: Memory Hierarchy –
Primary and Secondary Storage – Importance of Input
and Output Hardware, Types of Input and Output
Devices – Computer Terminals.



Introduction

• Early age computing??

• Digitus & Calculus

• Mechanism for Lengthy Calculations

• Compute -> Calculate

• Computer is an electronic machine devised for
performing calculations and controlling operations
that can be expressed either in numerical or logical
terms.





Characteristics of Computer

• Operations done by Computer:
– Calculation
– Data Processing
– Entertainment

• Characteristics:
– Speed - Storage
– Accuracy - Versatility
– Diligence - Resource Sharing
– Reliability



• Speed

– Extremely fast

– Million Instructions per Second (Mega Hertz)

– Billion Instructions per Second

• Accuracy

– Accurate Results

– Hardware and Type of Instruction

– GIGO

• Diligence

– No Tired or loss of concentration

– First and Last Calculation



• Reliability
– Measure of Performance

– Predetermined Standards

– Built-in Diagnostic Capabilities

• Storage
– Large amount of data & Instant Recall

– Main Memory and Secondary Storage

– Data Processing Steps

• Versatility
– Multiple Task simultaneously

• Resource Sharing
– Data and Devices can be shared





Classification of Computers



Micro Computer

• Small low cost digital computer.

• Components

– Microprocessor

– Storage unit

– Input Channel

– Output Channel

• Requires Power supply, peripherals, OS

• IBM PC, Apple Mac

• Classifications

– Desktop, Laptop and Hand Held



Micro Computer
• Desktop Computer (PC)

– System unit, Monitor, Keyboard, Hard disk

– Not much expensive

– Apple, IBM, Dell, HP

• Laptop Computer
– Portable Computer

– Rechargeable battery

– Resemble Notebooks

• Hand Held Computer
– Personal Digital Assistant

– Small cards for storage

– Apple Newton, Franklin eBookMan





Mini Computer

• Mid range between Micro and Main frame computers

• Size of two drawer cabinet

• Supports 4 to 200 users at a time

• Central server or Cluster of computers

• Real time applications in industries, universities, 

hospitals etc.,

• PDP 1, IBM 8000 series, VAX 7500





Mainframe Computer

• Ultra high performance computer for intensive

computing

• Large volume of data processing, online

transactions, extensive data storage and retrieval

• Maintain large information at central location

and high speed processing

• IBM ES000, CDC 6600





Super Computer

• Designed to maximize FLOPS

• Contains set of CPU for parallel processing

• 400 – 10000 FLOPS per second

• Fastest, Costliest and solve complex

mathematical and scientific problems

• CRAY-3, CYBER 205, PARAM





NETWORK TOPOLOGIES 

Network Topology is the schematic description of a network arrangement, connecting various 

nodes(sender and receiver) through lines of connection.  

Network Topologies  

BUS Topology Bus topology is a network type in which every computer and network device 

is connected to single cable. When it has exactly two endpoints, then it is called Linear Bus 

topology. 

Number of cables = n 

Features of Bus Topology  

 It transmits data only in one direction  

 Every device is connected to a single cable  

Advantages of Bus Topology  

 It is cost effective.  

 Cable required is least compared to other network topology.  

 Used in small networks.  

 It is easy to understand.  

 Easy to expand joining two cables together.  

Disadvantages of Bus Topology  

 Cables fails then whole network fails.  

 If network traffic is heavy or nodes are more the performance of the network 

decreases.  

 Cable has a limited length.  

 It is slower than the ring topology.  

RING Topology  

It is called ring topology because it forms a ring as each computer is connected to another 

computer, with the last one connected to the first. Exactly two neighbours for each device.  

Number of cables = n-1 

Features of Ring Topology  

A number of repeaters are used for Ring topology with large number of nodes, because if 

someone wants to send some data to the last node in the ring topology with 100 nodes, then 

the data will have to pass through 99 nodes to reach the 100th node. Hence to prevent data 

loss repeaters are used in the network. 



The transmission is unidirectional, but it can be made bidirectional by having 2 connections 

between each Network Node, it is called Dual Ring Topology. In Dual Ring Topology, two 

ring networks are formed, and data flow is in opposite direction in them. Also, if one ring 

fails, the second ring can act as a backup, to keep the network up. Data is transferred in a 

sequential manner that is bit by bit. Data transmitted, has to pass through each node of the 

network, till the destination node.  

Advantages of Ring Topology  

 Transmitting network is not affected by high traffic or by adding more nodes, as only 

the nodes having tokens can transmit data.  

 Cheap to install and expand  

Disadvantages of Ring Topology  

 Troubleshooting is difficult in ring topology.  

 Adding or deleting the computers disturbs the network activity.  

 Failure of one computer disturbs the whole network.  

STAR Topology  

In this type of topology all the computers are connected to a single hub through a cable. This 

hub is the central node and all others nodes are connected to the central node.  

Number of cables = n 

Features of Star Topology  

 Every node has its own dedicated connection to the hub.  

 Hub acts as a repeater for data flow.  

 Can be used with twisted pair, Optical Fibre or coaxial cable.  

Advantages of Star Topology  

 Fast performance with few nodes and low network traffic.  

 Hub can be upgraded easily.  

 Easy to troubleshoot.  

 Easy to setup and modify.  

 Only that node is affected which has failed, rest of the nodes can work smoothly.  

Disadvantages of Star Topology  

 Cost of installation is high.  

 Expensive to use.  

 If the hub fails then the whole network is stopped because all the nodes depend on the 

hub.  



 Performance is based on the hub that is it depends on its capacity  

MESH Topology It is a point-to-point connection to other nodes or devices. All the network 

nodes are connected to each other. Mesh has n(n-1)/2 physical channels to link n devices. 

Features of Mesh Topology  

 Fully connected.  

 Robust.  

 Not flexible.  

Advantages of Mesh Topology  

 Each connection can carry its own data load.  

 It is robust.  

 Fault is diagnosed easily.  

 Provides security and privacy.  

Disadvantages of Mesh Topology  

 Installation and configuration is difficult.  

 Cabling cost is more.  

 Bulk wiring is required.  

TREE Topology  

It has a root node and all other nodes are connected to it forming a hierarchy. It is also called 

hierarchical topology. It should at least have three levels to the hierarchy.  

Features of Tree Topology  

 Ideal if workstations are located in groups.  

 Used in Wide Area Network.  

Advantages of Tree Topology  

 Extension of bus and star topologies.  

 Expansion of nodes is possible and easy.  

 Easily managed and maintained.  

 Error detection is easily done.  

Disadvantages of Tree Topology  

 Heavily cabled.  

 Costly.  

 If more nodes are added maintenance is difficult.  

 Central hub fails, network fails.  

HYBRID Topology  



It is two different types of topologies which is a mixture of two or more topologies. For 

example if in an office in one department ring topology is used and in another star topology is 

used, connecting these topologies will result in Hybrid Topology (ring topology and star 

topology). 

Features of Hybrid Topology  

 It is a combination of two or topologies  

 Inherits the advantages and disadvantages of the topologies included  

Advantages of Hybrid Topology  

 Reliable as Error detecting and trouble shooting is easy.  

 Effective.  

 Scalable as size can be increased easily.  

 Flexible.  

Disadvantages of Hybrid Topology  

 Complex in design.  

 Costly.  
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Revision

• The types of computers based on size are 

• The first device used for calculation is

• ____ is a computer used for online transactions

• The super computers are mainly used for ____ 

purposes

• ____ property allows the computer to perform 

multiple tasks at the same time



Components of Computer

• Central Processing Unit (CPU)

– Arithmetic Logic Unit (ALU)

– Control Unit

– Memory Unit

• Input Unit

• Output Unit

• Storage Unit





Central Processing Unit

• Brain of the Computer

• Data as 1 or 0

• Work of CPU

– Count, compare, rearrange the data as required

– Convert them back to source data

• Circuits are fabricated in Microprocessor



Arithmetic Logic Unit

• Arithmetic and logical operation on data

• Data:

– Memory unit to ALU

– Process

– ALU to Memory unit

– To output unit



Control Unit

• Correct sequence of operation

• Get instruction from primary storage

• Verifies sequence and execute

• Control Input/Output devices

• Controls overall functioning



Memory Unit

• Primary memory

– Get data from input device

– Process the data

– Holds intermediate results 

– Provide results to output device



Simple Calculator

• 1 + 2 + 3

• 1 + 2 * 3

• (1 + 2) * 3



Input/ Output Unit

• Input/ Output unit:

– Communication media between computer and 

human

– Convert the data back and forth

– Keyboard, Mouse, Joystick

– Monitor, Speaker, Printer



Storage Unit

• Extensive storage of data and information

• Permanent storage

• Supply data to devices when required

• Main memory vs Secondary memory

• Floppy disk, Hard disk, Pendrive





Working of a Computer

• Three basic stages

• Store the results



Arithmetic Logic Unit

• Arithmetic and Logical operations on the data 
from registers

• Arithmetic unit

– Basic Arithmetic Operations

• Logic unit

– Equal to, Less than, Greater than

• Registers

– High speed memory





Register Purpose

Program Counter Tracks the next instruction

Instruction Register Currently executed instruction for decoding

Memory Address Register Address of next location to be accessed

Temporary Register Stores data to and from CPU

Accumulator Stores temporary results and results

Memory Data Register Stores operands and data



Control Unit

• Uses electrical signals to control the computer 

system Eg: Coach of the team

• Controls I/O devices and other data transfer to and 

from main memory

• Controls the data flow like storage, retrieval and 

execution

• Just controls does not perform!



System Bus



System Bus
• Set of connection between two or more 

components

• Multiple lines at 1 bit per line

• Data lines
– Moving data between modules (8,16,32)

• Address lines
– Designate the source of data

• Control lines
– Used to control access to data and address bus

– Timing and control signals



Memory Unit

• Main memory

– RAM

– ROM

• Cache memory

– L1 cache

– L2 cache

– L3 cache



Primary Memory:

It is used to store data temporary.

RAM

• Random Access Memory

• It is possible to randomly select and use any location

of the memory.

• It is a volatile memory i.e. It loose their content

when the power is switched off

• Static vs Dynamic
21



ROM

• Read Only Memory

• The data in the ROM is permanent .

• It is a non-volatile memories i.e. It does not loose
their content when the power is switched off .

PROM

• Programmable Read Only Memory

• It is supplied in blank by the manufacturer.

• It is possible to store program in PROM chip.

• Once the programmes are written it cannot be
changed and remain even if power is switched off.

22



• Erasable Programmable Read Only Memory.

• Information stored in EPROM can be erased by
exposing the chip in ultraviolet light and it is
reprogrammed using a special programming facility.

EEPROM

• Electrically Erasable Programmable Read Only
Memory.

• Information stored in EEPROM can be erased by
applying some voltage.

EPROM

23



Microsoft Word 

 Word processing is the manipulation of character, word, text, numbers, sentences and 

paragraphs in the document so that it is error free and looks attractive. 

To open Microsoft word: 

 Click Start -> All Programs -> Microsoft Word 

 Double click on the Microsoft Word icon located on the Desktop 

Word Environment: 

 It has a Title bar, Tool bar, Status bar, Menu bar and ruler with various options to manipulate 

the document. 

Help in Microsoft Word: 

 Press F1 or select Microsoft Word Help from Help menu. 

Features of Word Processing: 

Creating, Opening and Closing a document: 

 To create a new document, Select New from File menu and click on Blank Document. 

 To open an existing document, Select Open from File menu and click on the required 

document to be opened. 

 To close a document, Select Close from File menu or click on the close icon on the top right 

corner. 

Key board Shortcuts: 

Process to select Mouse Action Key board shortcut 

A word 
Double click anywhere on the 

word 
Ctrl + Shift + Right or Left 

Arrow 

A line 
Click on the left margin next to 

the line 
Shift + End or Shift + 

Home 

Multiple Lines 
Click on the left margin and 

keep on dragging till the desired 
lines to be selected 

Shift + Up or Down Arrow 

Paragraph 
Triple click anywhere in the 

paragraph 
Ctrl + Shift + Up or Down 

Arrow 

Entire Document Triple click on left margin Ctrl + A 

 

Cut, Copy and Paste in word: 

Process to do Mouse Action Key board shortcut 

Cut a Text Select the Text, Right click and select Cut Ctrl + X 



Copy a Text 
Select the Text, Right click and select 

Copy 
Ctrl + C 

Paste a Text 
Place the cursor in the required place, 

Right click and select Paste 
Ctrl + V 

 

Finding and Replacing Text: 

 Find and replace option is used to locate a particular word, phrase or set of characters in the 

word document and replace it with some other characters. 

Steps to find and replace: 

 Select Find from Edit menu to open the dialog box. 

 Click on Find tab, if you just want to find the desired text. 

 Click on Replace tab, if you want to find and replace a text. 

 In the Find what box, enter the text to find and enter the replacement text in the replace 

with text box. 

 Click Find next to find the first occurrence of the text and Replace to replace the first 

occurrence and Replace All to replace all the occurrences in the word document. 

Undo and Redo: 

 Word processing application remembers all the actions that are performed on a file. These 

actions can be reversed at anytime by the user. 

 To undo the last action, click on the undo icon on standard tool bar or select Undo from Edit 

menu. Clicking on the arrow near the undo icon displays the set of actions that can be selected. 

 To reverse an undo action, click on the Redo icon on standard tool bar or select Redo from 

Edit Menu. Certain action like saving a file, printing a document, closing a file cannot be undone. 

Bullets and Numbering: 

 To use bullets and numbering in the text, select the required text and click on bullets button 

or numbering button in the Formatting tool bar. 

 Select the required text and select Bullets and Numbering from Format menu, select the 

required type from the dialog box and click ok. 

 To remove the bullets and numbering, select the text and click on the Bullets or Numbering 

icon respectively. 

Table: 

 To insert a Table, select Table from the Insert menu, select the required number of rows and 

columns and click ok. 



 Select the Insert table icon on standard tool bar and select the required cells from the grid 

displayed. 

 A lot of formatting options are available to format the table in the Tables and Borders 

toolbar. 

 Table properties like size, alignment and others formatting options can be selected from this 

toolbar. 

Pictures: 

 To insert a picture in the document, Click on Picture from Insert menu and select from file 

and click on the desired picture to be inserted in the document. 

 To insert a clipart, select Clipart from the Insert menu and select the desired clipart to be 

inserted. 

 To insert a Shape, select Shapes from Insert menu and click on the desired shape to be 

inserted. 

 These can be resized by clicking on the down right corner and dragging it for the desired 

size. 

 


